Back to overview
Degraded
Enrichment API (US) is experiencing service degradation
Jan 16 at 10:05pm UTC
Affected services
Enrichment API Realtime (US)
Resolved
Jan 16 at 10:11pm UTC
Enrichment API (US) is back to normal
Affected services
Enrichment API Realtime (US)
Created
Jan 16 at 10:05pm UTC
Enrichment API (US) is experiencing service degradation
Affected services
Enrichment API Realtime (US)