Back to overview
Degraded

Enrichment API Batch (US) is experiencing service degradation

Aug 22 at 06:52pm UTC
Affected services
Enrichment API Batch (US)

Resolved
Aug 22 at 06:54pm UTC

Enrichment API Batch (US) is back to normal

Created
Aug 22 at 06:52pm UTC

Enrichment API Batch (US) is experiencing service degradation