Back to overview
Downtime
Dashboard (US), Enrichment API Realtime (US), and 1 other service are down
Sep 19 at 05:56pm UTC
Affected services
Dashboard (US)
Enrichment API Realtime (US)
Enrichment API Batch (US)
Resolved
Sep 19 at 06:00pm UTC
Dashboard (US), Enrichment API Realtime (US), and Enrichment API Batch (US) recovered.
Affected services
Dashboard (US)
Enrichment API Realtime (US)
Enrichment API Batch (US)
Created
Sep 19 at 05:56pm UTC
Dashboard (US), Enrichment API Realtime (US), and Enrichment API Batch (US) went down.
Affected services
Dashboard (US)
Enrichment API Realtime (US)
Enrichment API Batch (US)