Back to overview
Degraded
Enrichment API Batch (EU) is experiencing degradation
Oct 10 at 11:23am UTC
Affected services
Enrichment API Batch (EU)
Resolved
Oct 10 at 11:32am UTC
Enrichment API Batch (EU) recovered.
Affected services
Enrichment API Batch (EU)
Created
Oct 10 at 11:23am UTC
Enrichment API Batch (EU) is experiencing degradation.
Affected services
Enrichment API Batch (EU)